(troppo vecchio per rispondere)
Apertura porte e uso di telnet
Noixe
2010-02-20 16:09:05 UTC
Salve,

ho windows 7, ho attivato client e server di telnet, ma non riesco a
connettermi al mio stesso pc. Ho provato come indirizzi:
127.0.0.1
192.168.0.1
L'IP pubblico

ma in tutti i casi non riesce a trovare l'host.

Inoltre dalle impostazioni avanzate di windows firewall ho aperto delle
porte (tipo la 2 cosi per provare) ma il port scanner (nmap) non la rileva.
Anzi se faccio lo scan di 127.0.0.1 ne rileva molte, ma non quella aperta da
me, se faccio lo scan del ip pubblico o di 192.168.0.1 mi rileva solo le
porte 80, 5000 e 8080.

Ho un router NETGEAR DGN 2000, tra le opzioni ho visto che quella per aprire
le porte dovrebbe essere quella relativa ai servizi la quale dice:

Guida ai servizi
Il menu Servizi contiene un elenco di servizi definiti dall'utente per la
creazione di regole del firewall. Se un servizio non compare nell'elenco
predefinito Servizi del menu Regole del firewall, lo si può definire in
questo menu. Il nuovo servizio comparirà quindi nell'elenco Servizi del menu
Regole del firewall.

Tabella dei servizi
Questa tabella riporta un elenco di tutti i servizi che si sono definiti. Se
non si sono definiti servizi, la tabella sarà vuota.

Per creare un servizio

Fare clic su Aggiungi servizio personalizzato
Immettere i dati relativi al servizio secondo le necessità.
Fare clic su Applica per salvare il nuovo servizio.
Per modificare un servizio

Fare clic sul pulsante di opzione accanto ad un servizio della tabella.
Fare clic su Modifica servizio per visualizzare i dati del servizio nella
sezione "Definizione servizio".
Modificare i dati relativi al servizio secondo le necessità.
Fare clic su Applica per salvare le modifiche apportate.
Per cancellare un servizio

Fare clic sul pulsante di opzione accanto ad un servizio della tabella.
Fare clic su Elimina servizio per cancellare il servizio selezionato.


Quindi dovrebbe essere questa, ma anche qui le porte aperte non vengono
rilevate da nmap (il port scanner), ma forse perché non uso firewall del
router.

Nella sezione del firewall però c'è scritto:

Servizi in ingresso
Attiva: Si
Nome servizio: Qualsiasi
Azione: BLOCCA Sempre
Indirizzo IP server lan: qualsiasi
Utenti WAN: qualsiasi

Ma se clicco su modifica, non mi fa modificare niente, perché dice che devo
selezionare una voce, ma non è selezionabile alcuna voce.

Consigli?
Filippo Di Cesare
2010-02-20 18:09:24 UTC
Post by Noixe
Inoltre dalle impostazioni avanzate di windows firewall ho aperto delle
porte (tipo la 2 cosi per provare) ma il port scanner (nmap) non la rileva.
E' normale, se apri una porta ma poi non c'e' nessuno in ascolto su quella
porta, il port scanner la vede chiusa.
Post by Noixe
Consigli?
Esattamente cosa devi fare?
Noixe
2010-02-20 19:36:58 UTC
Post by Filippo Di Cesare
Post by Noixe
Inoltre dalle impostazioni avanzate di windows firewall ho aperto delle
porte (tipo la 2 cosi per provare) ma il port scanner (nmap) non la rileva.
E' normale, se apri una porta ma poi non c'e' nessuno in ascolto su quella
porta, il port scanner la vede chiusa.
Ah, serve qualcosa in ascolto allora, ok.
Post by Filippo Di Cesare
Post by Noixe
Consigli?
Esattamente cosa devi fare?
Vorrei riuscire a connettermi al mio stesso pc via telnet.
Ma forse il problema e' nel firewall del router, che sembra bloccare tutte
le connessioni entrata default.
Filippo Di Cesare
2010-02-21 14:31:59 UTC
Post by Noixe
Vorrei riuscire a connettermi al mio stesso pc via telnet.
Ma forse il problema e' nel firewall del router, che sembra bloccare tutte
le connessioni entrata default.
La porta del telnet e' la 25, collegandoti al tuo stesso pc basta che chiami
localhost e i pacchetti non escono dalla scheda di rete ma vengono
rimbalzati dentro, ergo il router non c'entra niente.
Basta che apri la porta 25 sul firewall di windows (e poi forse non e'
nemmeno necessario), lanci qualunque applicazione che si metta in scolto
sulla porta 25.
A quel punto fai telnet localhost e ti colleghi.
Noixe
2010-02-21 15:27:41 UTC
Post by Filippo Di Cesare
La porta del telnet e' la 25,
23
Post by Filippo Di Cesare
collegandoti al tuo stesso pc basta che chiami
localhost e i pacchetti non escono dalla scheda di rete ma vengono
rimbalzati dentro, ergo il router non c'entra niente.
Basta che apri la porta 25 sul firewall di windows (e poi forse non e'
nemmeno necessario), lanci qualunque applicazione che si metta in scolto
sulla porta 25.
A quel punto fai telnet localhost e ti colleghi.
Fatto sta che invece non c'e' verso di farlo connettere.
Filippo Di Cesare
2010-02-21 15:30:08 UTC
Post by Noixe
Post by Filippo Di Cesare
La porta del telnet e' la 25,
23
Si e' la 23
Post by Noixe
Fatto sta che invece non c'e' verso di farlo connettere.
eh.. sbaglierai qualcosa..
Pinotto
2010-02-21 15:37:41 UTC
Post by Filippo Di Cesare
La porta del telnet e' la 25,
23, default.
Noixe
2010-02-21 16:00:14 UTC
Post by Filippo Di Cesare
eh.. sbaglierai qualcosa..
Ma cosa?
Ho attivato il server e il client
digito:

telnet localhost premo invio

e dopo qualche secondo mi dice impossibile aprire una connessione con l'host
sulla porta 23: connessione non riuscita.
adriano
2010-02-21 16:04:33 UTC
Post by Noixe
Ma cosa?
Ho attivato il server e il client
che serve hai usato?

Adriano
adriano
2010-02-21 16:11:34 UTC
che server hai usato?
ho fatto una prova con il primo che mi e' capitato: KpyM
Boh....lanciato e poi provato ad autocollegarmi e funziona, senza dover
toccare altro. Dall'esterno suppongo che si dovra' aprire la porta 23
nel firewall di windows e impostare il port forwarding.
Verifica che dopo l'installazione non ci sia magari da fare qualche
operazione...magari avviare il servizio.
Nel caso anche tu abbia usato KpyM, sei certo di averlo installato in
modalita' telnet server e non ssh server? perche' in questo caso serve
un client apposito (per es. putty) e la porta e' la 22

Adriano
Noixe
2010-02-21 17:18:07 UTC
Post by adriano
ho fatto una prova con il primo che mi e' capitato: KpyM
[CUT]

Ho attivato il server telnet dalle opzioni di windows seven in programmi e
funzionalità.
Andato a vedere in windows firewall, appare questo nuovo servizio, in
ascolto sulla porta 23 e mi dice proprio che serve a consentire ad un pc
remoto di connettersi al mio tramite telnet.
Quindi dovrebbe essere tutto apposto, ma non riesco a connettermi lo stesso.

Come client uso sempre telnet, il quale funziona perché se provo a
connettermi altrove riesco senza problemi.
adriano
2010-02-21 18:03:56 UTC
Post by Noixe
Ho attivato il server telnet dalle opzioni di windows seven in programmi e
funzionalità.
Andato a vedere in windows firewall, appare questo nuovo servizio, in ascolto
sulla porta 23 e mi dice proprio che serve a consentire ad un pc remoto di
connettersi al mio tramite telnet.
Quindi dovrebbe essere tutto apposto, ma non riesco a connettermi lo stesso.
Come client uso sempre telnet, il quale funziona perché se provo a
connettermi altrove riesco senza problemi.
ok. ho provato ad attivare il telnet su un notebook con win7 e a
collegarmi dall'altro pc con xp. Al primo tentativo mi dice che
l'utente deve essere inserito nel gruppo telnetusers e mi sbatte fuori
Mi metto in quel gruppo (lato server) e la connessione funziona.
Ovviamente ho lo stesso utente/password sul pc client.
Detto questo, se quello che ti interessa e' solo provare per
curiosita', va anche bene. Se pensi di lasciare il server telnet
esposto ad internet, fallo almeno in tunnel ssh

Adriano
Noixe
2010-02-21 18:06:35 UTC
Post by adriano
ok. ho provato ad attivare il telnet su un notebook con win7 e a
collegarmi dall'altro pc con xp. Al primo tentativo mi dice che l'utente
deve essere inserito nel gruppo telnetusers e mi sbatte fuori
Mi metto in quel gruppo (lato server) e la connessione funziona.
A me da solo errore, non dice niente relativamente a gruppi a cui
appartenere.
adriano
2010-02-21 18:12:28 UTC
Post by Noixe
A me da solo errore, non dice niente relativamente a gruppi a cui
appartenere.
comunque prova a guardare se fra i gruppi e' comparso telnet users e
mettitici

Adriano
Noixe
2010-02-21 20:36:25 UTC
Post by adriano
comunque prova a guardare se fra i gruppi e' comparso telnet users e
mettitici
Io vedo solo workgroup.

Potresti dirmi di preciso dove si cambia il gruppo? Magari non lo trovo io.
Filippo Di Cesare
2010-02-21 20:47:16 UTC
Post by Noixe
Io vedo solo workgroup.
Potresti dirmi di preciso dove si cambia il gruppo? Magari non lo trovo io.
Il mio consiglio e' di usare un altro server telnet.

In giro ho trovato questo
http://webscripts.softpedia.com/script/Networking-Tools/Netcat-27515.html

Ciao
Filippo Di Cesare
2010-02-21 20:48:09 UTC
Post by Filippo Di Cesare
In giro ho trovato questo
http://webscripts.softpedia.com/script/Networking-Tools/Netcat-27515.html
mmm... gurdando meglio mi sa che questo questo e' solo un client

prova questo
http://www.soft32.com/download_76236.html

Ciao
Noixe
2010-02-21 21:08:27 UTC
Post by Filippo Di Cesare
prova questo
http://www.soft32.com/download_76236.html
Va bè non era così importante da richiedere un server apposta, volevo solo
capire perché non funzionava quello di windows :D
nameci
2010-02-22 17:57:54 UTC
Post by Noixe
sulla porta 23 e mi dice proprio che serve a consentire ad un pc remoto
di connettersi al mio tramite telnet.
Ma hai avviato il servizio? se da prompt comandi esegui netstat -na|find
"23" trovi la porta in listening?
--
************** (.)_(.) *******************
Un amico è uno che sa tutto di te e,
nonostante questo, gli piaci
(E. Hobbard)
adriano
2010-02-22 19:23:05 UTC
Post by Noixe
Potresti dirmi di preciso dove si cambia il gruppo? Magari non lo trovo io.
clicca col destro su risorse del computer, scegli gestione quindi
utenti e gruppi

Adriano

Pagina Successiva >
Pagina 1 di 2